aboutsummaryrefslogtreecommitdiff
path: root/examples/main/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/main/CMakeLists.txt')
-rw-r--r--examples/main/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/main/CMakeLists.txt b/examples/main/CMakeLists.txt
new file mode 100644
index 0000000..b2dcc29
--- /dev/null
+++ b/examples/main/CMakeLists.txt
@@ -0,0 +1,4 @@
+set(TARGET main)
+add_executable(${TARGET} main.cpp)
+target_link_libraries(${TARGET} PRIVATE common llama ${CMAKE_THREAD_LIBS_INIT})
+target_compile_features(${TARGET} PRIVATE cxx_std_11)