aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index cebb47b..a595530 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,7 +26,7 @@
[ ];
pkgs = import nixpkgs { inherit system; };
llama-python =
- pkgs.python310.withPackages (ps: with ps; [ numpy sentencepiece ]);
+ pkgs.python310.withPackages (ps: with ps; [ numpy sentencepiece pip ]);
in {
packages.default = pkgs.stdenv.mkDerivation {
name = "llama.cpp";
@@ -38,7 +38,7 @@
"";
nativeBuildInputs = with pkgs; [ cmake ];
buildInputs = osSpecific;
- cmakeFlags = [ "-DLLAMA_BUILD_SERVER=ON" ] ++ (optionals isM1 [
+ cmakeFlags = [ "-DLLAMA_BUILD_SERVER=ON" "-DLLAMA_LTO=ON" "-DLLAMA_SANITIZE_THREAD=OFF -DLAMMA_SANITIZE_ADRRESS=ON" "-DLLAMA_SANITIZE_UNDEFINED=ON" ] ++ (optionals isM1 [
"-DCMAKE_C_FLAGS=-D__ARM_FEATURE_DOTPROD=1"
"-DLLAMA_METAL=ON"
]);
@@ -48,9 +48,9 @@
mv $out/bin/main $out/bin/llama
mv $out/bin/server $out/bin/llama-server
- echo "#!${llama-python}/bin/python" > $out/bin/convert.py
- cat ${./convert.py} >> $out/bin/convert.py
- chmod +x $out/bin/convert.py
+ echo "#!${llama-python}/bin/python" > $out/bin/llama-convert.py
+ cat ${./convert.py} >> $out/bin/llama-convert.py
+ chmod +x $out/bin/llama-convert.py
'';
meta.mainProgram = "llama";
};