aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authoraditya <bluenerd@protonmail.com>2023-06-07 17:50:29 +0530
committeraditya <bluenerd@protonmail.com>2023-06-07 17:50:29 +0530
commitbdcdee9e0940f63b65708736ee671f6e2c731994 (patch)
tree75d32eb02b90a003780b276b613b6a99169c5239 /flake.nix
parent075f2df85238bd00b4856984ac23c0d8532aacc3 (diff)
update git submodule url
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..b59edb8
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,19 @@
+{
+ description = "A flake for publishing blog posts to https://blog.adityakumar.xyz/";
+
+ inputs.nixpkgs.url = "github:nixos/nixpkgs/23.05";
+
+ outputs = { self, nixpkgs }: {
+ with import nixpkgs { system = "x86_64-linux"; };
+ stdenv.mkDerivation {
+ name = "blog";
+ buildInputs = [
+ pkgs.hugo
+ pkgs.rsync
+ ];
+ src = self;
+ buildPhase = "hugo server";
+ installPhase = "./deploy.sh"
+ };
+ };
+}