aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwzy <32936898+Freed-Wu@users.noreply.github.com>2023-07-19 15:01:55 +0800
committerGitHub <noreply@github.com>2023-07-19 10:01:55 +0300
commit45a1b07e9b20c33d71d8c849ff27d693a75a0269 (patch)
tree40ac1d0a457b130ecaf21cfec8d0f75948728263 /CMakeLists.txt
parentb1f429095328a34556c0e9a7a2fefced3db3368c (diff)
flake : update flake.nix (#2270)
When `isx86_32 || isx86_64`, it will use mkl, else openblas According to https://discourse.nixos.org/t/rpath-of-binary-contains-a-forbidden-reference-to-build/12200/3, add -DCMAKE_SKIP_BUILD_RPATH=ON Fix #2261, Nix doesn't provide mkl-sdl.pc. When we build with -DBUILD_SHARED_LIBS=ON, -DLLAMA_BLAS_VENDOR=Intel10_lp64 replace mkl-sdl.pc by mkl-dynamic-lp64-iomp.pc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index abc9681..1693327 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -186,7 +186,16 @@ if (LLAMA_BLAS)
pkg_check_modules(DepBLAS REQUIRED flexiblas_api)
elseif (${LLAMA_BLAS_VENDOR} MATCHES "Intel")
# all Intel* libraries share the same include path
- pkg_check_modules(DepBLAS REQUIRED mkl-sdl)
+ pkg_check_modules(DepBLAS mkl-sdl)
+ if (NOT DepBLAS)
+ if (BUILD_SHARED_LIBS)
+ set(LINK_METHOD dynamic)
+ else()
+ set(LINK_METHOD static)
+ endif()
+ string(REGEX REPLACE ".*_" "" DATA_TYPE_MODEL ${LLAMA_BLAS_VENDOR})
+ pkg_check_modules(DepBLAS REQUIRED mkl-${LINK_METHOD}-${DATA_TYPE_MODEL}-iomp)
+ endif()
elseif (${LLAMA_BLAS_VENDOR} MATCHES "NVHPC")
# this doesn't provide pkg-config
# suggest to assign BLAS_INCLUDE_DIRS on your own