aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwzy <32936898+Freed-Wu@users.noreply.github.com>2023-07-21 18:26:34 +0800
committerGitHub <noreply@github.com>2023-07-21 13:26:34 +0300
commit78a3d13424b01c3f8ea94ea7e59650ab0501e902 (patch)
tree41d83c938b298c21fdb7140f5ea8096a09896568 /CMakeLists.txt
parentae178ab46bfd6ecb2422da5dad441a4e2fef8b7e (diff)
flake : remove intel mkl from flake.nix due to missing files (#2277)
NixOS's mkl misses some libraries like mkl-sdl.pc. See #2261 Currently NixOS doesn't have intel C compiler (icx, icpx). See https://discourse.nixos.org/t/packaging-intel-math-kernel-libraries-mkl/975 So remove it from flake.nix Some minor changes: - Change pkgs.python310 to pkgs.python3 to keep latest - Add pkgconfig to devShells.default - Remove installPhase because we have `cmake --install` from #2256
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1693327..abc9681 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -186,16 +186,7 @@ if (LLAMA_BLAS)
pkg_check_modules(DepBLAS REQUIRED flexiblas_api)
elseif (${LLAMA_BLAS_VENDOR} MATCHES "Intel")
# all Intel* libraries share the same include path
- pkg_check_modules(DepBLAS mkl-sdl)
- if (NOT DepBLAS)
- if (BUILD_SHARED_LIBS)
- set(LINK_METHOD dynamic)
- else()
- set(LINK_METHOD static)
- endif()
- string(REGEX REPLACE ".*_" "" DATA_TYPE_MODEL ${LLAMA_BLAS_VENDOR})
- pkg_check_modules(DepBLAS REQUIRED mkl-${LINK_METHOD}-${DATA_TYPE_MODEL}-iomp)
- endif()
+ pkg_check_modules(DepBLAS REQUIRED mkl-sdl)
elseif (${LLAMA_BLAS_VENDOR} MATCHES "NVHPC")
# this doesn't provide pkg-config
# suggest to assign BLAS_INCLUDE_DIRS on your own