aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSteward Garcia <57494570+FSSRepo@users.noreply.github.com>2023-05-21 11:51:18 -0600
committerGitHub <noreply@github.com>2023-05-21 20:51:18 +0300
commit7e4ea5beff567f53be92f75f9089e6f11fa5dabd (patch)
tree1979bd9d613a00c047885651ea36230fdfad6218 /CMakeLists.txt
parent7780e4f479dc5af106287c164b8e186cd9b6215c (diff)
examples : add server example with REST API (#1443)
* Added httplib support * Added readme for server example * fixed some bugs * Fix the build error on Macbook * changed json11 to nlohmann-json * removed some whitespaces * remove trailing whitespace * added support custom prompts and more functions * some corrections and added as cmake option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c9afed..3471e44 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,6 +72,7 @@ option(LLAMA_CLBLAST "llama: use CLBlast"
option(LLAMA_BUILD_TESTS "llama: build tests" ${LLAMA_STANDALONE})
option(LLAMA_BUILD_EXAMPLES "llama: build examples" ${LLAMA_STANDALONE})
+option(LLAMA_BUILD_SERVER "llama: build server example" OFF)
#
# Build info header