aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Lütke <tobi@shopify.com>2023-07-04 10:05:27 -0400
committerGitHub <noreply@github.com>2023-07-04 16:05:27 +0200
commit7ee76e45afae7f9a7a53e93393accfb5b36684e1 (patch)
tree113fc52e6b154de3d1b1c39fbcae1ab002f884e6 /CMakeLists.txt
parentacc111caf93fc6681450924df9f99679c384c59e (diff)
Simple webchat for server (#1998)
* expose simple web interface on root domain * embed index and add --path for choosing static dir * allow server to multithread because web browsers send a lot of garbage requests we want the server to multithread when serving 404s for favicon's etc. To avoid blowing up llama we just take a mutex when it's invoked. * let's try this with the xxd tool instead and see if msvc is happier with that * enable server in Makefiles * add /completion.js file to make it easy to use the server from js * slightly nicer css * rework state management into session, expose historyTemplate to settings --------- Co-authored-by: Georgi Gerganov <ggerganov@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34a8973..4ac0f6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,7 +79,7 @@ option(LLAMA_QKK_64 "llama: use super-block size of 64
option(LLAMA_BUILD_TESTS "llama: build tests" ${LLAMA_STANDALONE})
option(LLAMA_BUILD_EXAMPLES "llama: build examples" ${LLAMA_STANDALONE})
-option(LLAMA_BUILD_SERVER "llama: build server example" OFF)
+option(LLAMA_BUILD_SERVER "llama: build server example" ON)
#
# Build info header