aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorslaren <slarengh@gmail.com>2023-07-30 15:58:01 +0200
committerGitHub <noreply@github.com>2023-07-30 15:58:01 +0200
commita113689571420fb4d6540f1a324d12965781356a (patch)
tree7ae5da392644f6c72e49aa88137a77875239dfe8 /CMakeLists.txt
parent11f3ca06b8c66b0427aab0a472479da22553b472 (diff)
ggml : add graph tensor allocator (#2411)
* ggml : add graph tensor allocator * ggml : don't calculate data pointer of unallocated tensors when creating a view with an offset * ggml : refactor ggml_view_Nd into ggml_view_tensor_offset
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6e1abea..57678a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -503,6 +503,8 @@ endif()
add_library(ggml OBJECT
ggml.c
ggml.h
+ ggml-alloc.c
+ ggml-alloc.h
${GGML_SOURCES_CUDA}
${GGML_SOURCES_OPENCL}
${GGML_SOURCES_METAL}