aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorgi Gerganov <ggerganov@gmail.com>2023-03-28 19:51:55 +0300
committerGeorgi Gerganov <ggerganov@gmail.com>2023-03-28 19:51:55 +0300
commitd502bc7c9d9d6dfb3a09aea404395b666d7b374d (patch)
treed29e28de435e150a9a546e4724150834bc39a5a3 /CMakeLists.txt
parent436e56193199a1625f8c561069f702e8840a9e08 (diff)
tests : free llama context at the end of the test
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 241be4c..d7b0eba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -129,13 +129,14 @@ if (LLAMA_ALL_WARNINGS)
-Wshadow
-Wstrict-prototypes
-Wpointer-arith
+ -Wno-unused-function
)
set(cxx_flags
-Wall
-Wextra
-Wpedantic
-Wcast-qual
- -Wdouble-promotion
+ -Wno-unused-function
)
else()
# todo : msvc