aboutsummaryrefslogtreecommitdiff
path: root/examples/quantize/CMakeLists.txt
diff options
context:
space:
mode:
authorDannyDaemonic <DannyDaemonic@gmail.com>2023-05-01 09:23:47 -0700
committerGitHub <noreply@github.com>2023-05-01 18:23:47 +0200
commitf4cef87edfd1b2f8d5befd4fde54ca2e03987bea (patch)
treeb63939423df54fa5714e964e19e830811a990064 /examples/quantize/CMakeLists.txt
parent58b367c2d757c0ea12aec672382462b42204c724 (diff)
Add git-based build information for better issue tracking (#1232)
* Add git-based build information for better issue tracking * macOS fix * "build (hash)" and "CMAKE_SOURCE_DIR" changes * Redo "CMAKE_CURRENT_SOURCE_DIR" and clearer build messages * Fix conditional dependency on missing target * Broke out build-info.cmake, added find_package fallback, and added build into to all examples, added dependencies to Makefile * 4 space indenting for cmake, attempt to clean up my mess in Makefile * Short hash, less fancy Makefile, and don't modify build-info.h if it wouldn't change it
Diffstat (limited to 'examples/quantize/CMakeLists.txt')
-rw-r--r--examples/quantize/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/quantize/CMakeLists.txt b/examples/quantize/CMakeLists.txt
index fb27d45..475fc8b 100644
--- a/examples/quantize/CMakeLists.txt
+++ b/examples/quantize/CMakeLists.txt
@@ -2,3 +2,6 @@ set(TARGET quantize)
add_executable(${TARGET} quantize.cpp)
target_link_libraries(${TARGET} PRIVATE llama ${CMAKE_THREAD_LIBS_INIT})
target_compile_features(${TARGET} PRIVATE cxx_std_11)
+if(TARGET BUILD_INFO)
+ add_dependencies(${TARGET} BUILD_INFO)
+endif()