aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAndrei <abetlen@gmail.com>2023-06-10 10:47:34 -0400
committerGitHub <noreply@github.com>2023-06-10 17:47:34 +0300
commit303f5809f1b4ec49823dbe70cacd2124ec1d0df0 (patch)
tree0e1e6532b4b33e05a53453ed2093ad0a1a4dafef /flake.nix
parent059e99066d95d73d1ca26c3375d47c0e35596229 (diff)
metal : fix issue with ggml-metal.metal path. Closes #1769 (#1782)
* Fix issue with ggml-metal.metal path * Add ggml-metal.metal as a resource for llama target * Update flake.nix metal kernel substitution
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 6191004..f3180c8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -28,7 +28,7 @@
postPatch =
if isM1 then ''
substituteInPlace ./ggml-metal.m \
- --replace '[[NSBundle mainBundle] pathForResource:@"ggml-metal" ofType:@"metal"];' "@\"$out/ggml-metal.metal\";"
+ --replace '[bundle pathForResource:@"ggml-metal" ofType:@"metal"];' "@\"$out/ggml-metal.metal\";"
'' else "";
nativeBuildInputs = with pkgs; [ cmake ];
buildInputs = osSpecific;