aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorlon <114724657+longregen@users.noreply.github.com>2023-04-08 07:04:23 -0300
committerGitHub <noreply@github.com>2023-04-08 12:04:23 +0200
commit317fb12fbd7cef5d86476574bffe0e904af884ca (patch)
treeea7709ac224bd0f079bd2b416ccacdeb17bdf1c2 /flake.nix
parent62cfc54f77e519057110265b52b0d614fa363e2a (diff)
Add new binaries to flake.nix (#847)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 4c2717e..cd1b6d2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -30,6 +30,9 @@
mkdir -p $out/bin
mv bin/main $out/bin/llama
mv bin/quantize $out/bin/quantize
+ mv bin/embedding $out/bin/embedding
+ mv bin/perplexity $out/bin/perplexity
+
echo "#!${llama-python}/bin/python" > $out/bin/convert-pth-to-ggml
cat ${./convert-pth-to-ggml.py} >> $out/bin/convert-pth-to-ggml
chmod +x $out/bin/convert-pth-to-ggml