aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorwzy <32936898+Freed-Wu@users.noreply.github.com>2023-07-21 18:26:34 +0800
committerGitHub <noreply@github.com>2023-07-21 13:26:34 +0300
commit78a3d13424b01c3f8ea94ea7e59650ab0501e902 (patch)
tree41d83c938b298c21fdb7140f5ea8096a09896568 /flake.nix
parentae178ab46bfd6ecb2422da5dad441a4e2fef8b7e (diff)
flake : remove intel mkl from flake.nix due to missing files (#2277)
NixOS's mkl misses some libraries like mkl-sdl.pc. See #2261 Currently NixOS doesn't have intel C compiler (icx, icpx). See https://discourse.nixos.org/t/packaging-intel-math-kernel-libraries-mkl/975 So remove it from flake.nix Some minor changes: - Change pkgs.python310 to pkgs.python3 to keep latest - Add pkgconfig to devShells.default - Remove installPhase because we have `cmake --install` from #2256
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix27
1 files changed, 7 insertions, 20 deletions
diff --git a/flake.nix b/flake.nix
index 5657e82..7f148f1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,7 +6,7 @@
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem (system:
let
- inherit (pkgs.stdenv) isAarch32 isAarch64 isx86_32 isx86_64 isDarwin;
+ inherit (pkgs.stdenv) isAarch32 isAarch64 isDarwin;
osSpecific = with pkgs; [ openmpi ] ++
(
if isAarch64 && isDarwin then
@@ -22,14 +22,13 @@
CoreGraphics
CoreVideo
]
- else if isx86_32 || isx86_64 then
- with pkgs; [ mkl ]
else
with pkgs; [ openblas ]
);
pkgs = import nixpkgs { inherit system; };
+ nativeBuildInputs = with pkgs; [ cmake pkgconfig ];
llama-python =
- pkgs.python310.withPackages (ps: with ps; [ numpy sentencepiece ]);
+ pkgs.python3.withPackages (ps: with ps; [ numpy sentencepiece ]);
in {
packages.default = pkgs.stdenv.mkDerivation {
name = "llama.cpp";
@@ -37,33 +36,21 @@
postPatch = ''
substituteInPlace ./ggml-metal.m \
--replace '[bundle pathForResource:@"ggml-metal" ofType:@"metal"];' "@\"$out/bin/ggml-metal.metal\";"
+ substituteInPlace ./*.py --replace '/usr/bin/env python' '${llama-python}/bin/python'
'';
- nativeBuildInputs = with pkgs; [ cmake pkgconfig ];
+ nativeBuildInputs = nativeBuildInputs;
buildInputs = osSpecific;
cmakeFlags = [ "-DLLAMA_BUILD_SERVER=ON" "-DLLAMA_MPI=ON" "-DBUILD_SHARED_LIBS=ON" "-DCMAKE_SKIP_BUILD_RPATH=ON" ]
++ (if isAarch64 && isDarwin then [
"-DCMAKE_C_FLAGS=-D__ARM_FEATURE_DOTPROD=1"
"-DLLAMA_METAL=ON"
- ] else if isx86_32 || isx86_64 then [
- "-DLLAMA_BLAS=ON"
- "-DLLAMA_BLAS_VENDOR=Intel10_lp64"
] else [
"-DLLAMA_BLAS=ON"
"-DLLAMA_BLAS_VENDOR=OpenBLAS"
]);
- installPhase = ''
- runHook preInstall
-
- install -D bin/* -t $out/bin
- install -Dm644 lib*.so -t $out/lib
+ postInstall = ''
mv $out/bin/main $out/bin/llama
mv $out/bin/server $out/bin/llama-server
-
- echo "#!${llama-python}/bin/python" > $out/bin/convert.py
- cat ${./convert.py} >> $out/bin/convert.py
- chmod +x $out/bin/convert.py
-
- runHook postInstall
'';
meta.mainProgram = "llama";
};
@@ -81,7 +68,7 @@
};
apps.default = self.apps.${system}.llama;
devShells.default = pkgs.mkShell {
- packages = with pkgs; [ cmake llama-python ] ++ osSpecific;
+ packages = nativeBuildInputs ++ osSpecific;
};
});
}