aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorNiklas Korz <niklas@niklaskorz.de>2023-03-17 23:03:48 +0100
committerGitHub <noreply@github.com>2023-03-17 23:03:48 +0100
commita29274789309029fd88a9465e6d0832d4632272b (patch)
tree61943cb17a2ea377351e137ff579d8165516428d /flake.nix
parentc9f670a17755311aa28c411f5c7f3c8c05434770 (diff)
Nix flake (#40)
* Nix flake * Nix: only add Accelerate framework on macOS * Nix: development shel, direnv and compatibility * Nix: use python packages supplied by withPackages * Nix: remove channel compatibility * Nix: fix ARM neon dotproduct on macOS --------- Co-authored-by: Pavol Rusnak <pavol@rusnak.io>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..dae4ff6
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,48 @@
+{
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = import nixpkgs {
+ inherit system;
+ };
+ llama-python = pkgs.python310.withPackages (ps: with ps; [
+ torch
+ numpy
+ sentencepiece
+ ]);
+ in
+ {
+ packages.default = pkgs.stdenv.mkDerivation {
+ name = "llama.cpp";
+ src = ./.;
+ nativeBuildInputs = with pkgs; [ cmake ];
+ buildInputs = with pkgs; lib.optionals stdenv.isDarwin [
+ darwin.apple_sdk.frameworks.Accelerate
+ ];
+ cmakeFlags = with pkgs; lib.optionals (system == "aarch64-darwin") [
+ "-DCMAKE_C_FLAGS=-D__ARM_FEATURE_DOTPROD=1"
+ ];
+ installPhase = ''
+ mkdir -p $out/bin
+ mv llama $out/bin/llama
+ mv quantize $out/bin/quantize
+ echo "#!${llama-python}/bin/python" > $out/bin/convert-pth-to-ggml
+ cat ${./convert-pth-to-ggml.py} >> $out/bin/convert-pth-to-ggml
+ chmod +x $out/bin/convert-pth-to-ggml
+ '';
+ };
+ devShells.default = pkgs.mkShell {
+ packages = with pkgs; [
+ cmake
+ llama-python
+ ] ++ lib.optionals stdenv.isDarwin [
+ darwin.apple_sdk.frameworks.Accelerate
+ ];
+ };
+ }
+ );
+}