aboutsummaryrefslogtreecommitdiff
path: root/pocs/CMakeLists.txt
diff options
context:
space:
mode:
authorKawrakow <48489457+ikawrakow@users.noreply.github.com>2023-04-18 21:00:14 +0200
committerGitHub <noreply@github.com>2023-04-18 19:00:14 +0000
commit5ecff35151156118c2df74899637ad34ee384b9b (patch)
tree7fb7a564ef23ccdb832a8c3d96f5a49b75c1d7da /pocs/CMakeLists.txt
parent7faa7460f03bdd88becf1e659cf359f274055404 (diff)
Adding a simple program to measure speed of dot products (#1041)
On my Mac, the direct Q4_1 product is marginally slower (~69 vs ~55 us for Q4_0). The SIMD-ified ggml version is now almost 2X slower (~121 us). On a Ryzen 7950X CPU, the direct product for Q4_1 quantization is faster than the AVX2 implementation (~60 vs ~62 us). --------- Co-authored-by: Iwan Kawrakow <iwan.kawrakow@gmail.com>
Diffstat (limited to 'pocs/CMakeLists.txt')
-rw-r--r--pocs/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/pocs/CMakeLists.txt b/pocs/CMakeLists.txt
new file mode 100644
index 0000000..03e1d2c
--- /dev/null
+++ b/pocs/CMakeLists.txt
@@ -0,0 +1,12 @@
+# dependencies
+
+find_package(Threads REQUIRED)
+
+# third-party
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+if (EMSCRIPTEN)
+else()
+ add_subdirectory(vdot)
+endif()