aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07443e9..6bec1f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -140,6 +140,7 @@ if (LLAMA_ALL_WARNINGS)
-Wpedantic
-Wcast-qual
-Wno-unused-function
+ -Wno-multichar
)
else()
# todo : msvc
@@ -152,6 +153,10 @@ if (LLAMA_ALL_WARNINGS)
endif()
+if (MSVC)
+ add_compile_definitions(_CRT_SECURE_NO_WARNINGS)
+endif()
+
if (LLAMA_LTO)
include(CheckIPOSupported)
check_ipo_supported(RESULT result OUTPUT output)
@@ -241,7 +246,9 @@ endif()
add_library(llama
llama.cpp
- llama.h)
+ llama.h
+ llama_internal.h
+ llama_util.h)
target_include_directories(llama PUBLIC .)
target_compile_features(llama PUBLIC cxx_std_11) # don't bump