aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix100
1 files changed, 61 insertions, 39 deletions
diff --git a/flake.nix b/flake.nix
index a595530..c3406c7 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,52 +6,74 @@
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem (system:
let
- inherit (pkgs.stdenv) isAarch64 isDarwin;
- inherit (pkgs.lib) optionals;
- isM1 = isAarch64 && isDarwin;
- osSpecific = if isM1 then
- with pkgs.darwin.apple_sdk_11_0.frameworks; [
- Accelerate
- MetalKit
- MetalPerformanceShaders
- MetalPerformanceShadersGraph
- ]
- else if isDarwin then
- with pkgs.darwin.apple_sdk.frameworks; [
- Accelerate
- CoreGraphics
- CoreVideo
- ]
- else
- [ ];
+ inherit (pkgs.stdenv) isAarch32 isAarch64 isDarwin;
+ buildInputs = with pkgs; [ openmpi ];
+ osSpecific = with pkgs; buildInputs ++
+ (
+ if isAarch64 && isDarwin then
+ with pkgs.darwin.apple_sdk_11_0.frameworks; [
+ Accelerate
+ MetalKit
+ MetalPerformanceShaders
+ MetalPerformanceShadersGraph
+ ]
+ else if isAarch32 && isDarwin then
+ with pkgs.darwin.apple_sdk.frameworks; [
+ Accelerate
+ CoreGraphics
+ CoreVideo
+ ]
+ else
+ with pkgs; [ openblas ]
+ );
pkgs = import nixpkgs { inherit system; };
+ nativeBuildInputs = with pkgs; [ cmake pkgconfig ];
llama-python =
- pkgs.python310.withPackages (ps: with ps; [ numpy sentencepiece pip ]);
+ pkgs.python3.withPackages (ps: with ps; [ numpy sentencepiece ]);
+ postPatch = ''
+ substituteInPlace ./ggml-metal.m \
+ --replace '[bundle pathForResource:@"ggml-metal" ofType:@"metal"];' "@\"$out/bin/ggml-metal.metal\";"
+ substituteInPlace ./*.py --replace '/usr/bin/env python' '${llama-python}/bin/python'
+ '';
+ postInstall = ''
+ mkdir -p $out/bin
+ mv bin/* $out/bin/
+ mv $out/bin/main $out/bin/llama
+ mv $out/bin/server $out/bin/llama-server
+
+ echo "#!${llama-python}/bin/python" > $out/bin/llama-convert.py
+ cat ${./convert.py} >> $out/bin/llama-convert.py
+ chmod +x $out/bin/llama-convert.py
+ '';
+ cmakeFlags = [ "-DLLAMA_BUILD_SERVER=ON" "-DLLAMA_MPI=ON" "-DBUILD_SHARED_LIBS=ON" "-DCMAKE_SKIP_BUILD_RPATH=ON" "-DLLAMA_LTO=ON" "-DLLAMA_SANITIZE_THREAD=OFF -DLAMMA_SANITIZE_ADRRESS=ON" "-DLLAMA_SANITIZE_UNDEFINED=ON" ];
in {
packages.default = pkgs.stdenv.mkDerivation {
name = "llama.cpp";
src = ./.;
- postPatch = if isM1 then ''
- substituteInPlace ./ggml-metal.m \
- --replace '[bundle pathForResource:@"ggml-metal" ofType:@"metal"];' "@\"$out/bin/ggml-metal.metal\";"
- '' else
- "";
- nativeBuildInputs = with pkgs; [ cmake ];
+ postPatch = postPatch;
+ nativeBuildInputs = nativeBuildInputs;
buildInputs = osSpecific;
- cmakeFlags = [ "-DLLAMA_BUILD_SERVER=ON" "-DLLAMA_LTO=ON" "-DLLAMA_SANITIZE_THREAD=OFF -DLAMMA_SANITIZE_ADRRESS=ON" "-DLLAMA_SANITIZE_UNDEFINED=ON" ] ++ (optionals isM1 [
- "-DCMAKE_C_FLAGS=-D__ARM_FEATURE_DOTPROD=1"
- "-DLLAMA_METAL=ON"
+ cmakeFlags = cmakeFlags
+ ++ (if isAarch64 && isDarwin then [
+ "-DCMAKE_C_FLAGS=-D__ARM_FEATURE_DOTPROD=1"
+ "-DLLAMA_METAL=ON"
+ ] else [
+ "-DLLAMA_BLAS=ON"
+ "-DLLAMA_BLAS_VENDOR=OpenBLAS"
]);
- installPhase = ''
- mkdir -p $out/bin
- mv bin/* $out/bin/
- mv $out/bin/main $out/bin/llama
- mv $out/bin/server $out/bin/llama-server
-
- echo "#!${llama-python}/bin/python" > $out/bin/llama-convert.py
- cat ${./convert.py} >> $out/bin/llama-convert.py
- chmod +x $out/bin/llama-convert.py
- '';
+ postInstall = postInstall;
+ meta.mainProgram = "llama";
+ };
+ packages.opencl = pkgs.stdenv.mkDerivation {
+ name = "llama.cpp";
+ src = ./.;
+ postPatch = postPatch;
+ nativeBuildInputs = nativeBuildInputs;
+ buildInputs = with pkgs; buildInputs ++ [ clblast ];
+ cmakeFlags = cmakeFlags ++ [
+ "-DLLAMA_CLBLAST=ON"
+ ];
+ postInstall = postInstall;
meta.mainProgram = "llama";
};
apps.llama-server = {
@@ -68,7 +90,7 @@
};
apps.default = self.apps.${system}.llama;
devShells.default = pkgs.mkShell {
- packages = with pkgs; [ cmake llama-python ] ++ osSpecific;
+ packages = nativeBuildInputs ++ osSpecific;
};
});
}