aboutsummaryrefslogtreecommitdiff
path: root/examples/perplexity/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/perplexity/CMakeLists.txt')
-rw-r--r--examples/perplexity/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/perplexity/CMakeLists.txt b/examples/perplexity/CMakeLists.txt
new file mode 100644
index 0000000..5836df8
--- /dev/null
+++ b/examples/perplexity/CMakeLists.txt
@@ -0,0 +1,4 @@
+set(TARGET perplexity)
+add_executable(${TARGET} perplexity.cpp)
+target_link_libraries(${TARGET} PRIVATE common llama ${CMAKE_THREAD_LIBS_INIT})
+target_compile_features(${TARGET} PRIVATE cxx_std_11)