aboutsummaryrefslogtreecommitdiff
path: root/examples/perplexity/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorgi Gerganov <ggerganov@gmail.com>2023-03-25 20:26:40 +0200
committerGeorgi Gerganov <ggerganov@gmail.com>2023-03-25 20:26:40 +0200
commita316a425d04027453dc0fd45f003b647c12f66f9 (patch)
treeb33d7c55741f10f1cc84f489df05e1fad96f0417 /examples/perplexity/CMakeLists.txt
parentecbe466a364876927994e2f1ec14f4d82301d201 (diff)
Overhaul the examples structure
- main -> examples - utils -> examples (renamed to "common") - quantize -> examples - separate tools for "perplexity" and "embedding" Hope I didn't break something !
Diffstat (limited to 'examples/perplexity/CMakeLists.txt')
-rw-r--r--examples/perplexity/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/perplexity/CMakeLists.txt b/examples/perplexity/CMakeLists.txt
new file mode 100644
index 0000000..5836df8
--- /dev/null
+++ b/examples/perplexity/CMakeLists.txt
@@ -0,0 +1,4 @@
+set(TARGET perplexity)
+add_executable(${TARGET} perplexity.cpp)
+target_link_libraries(${TARGET} PRIVATE common llama ${CMAKE_THREAD_LIBS_INIT})
+target_compile_features(${TARGET} PRIVATE cxx_std_11)